Version: eXtendFiles 1.7.0 and above
Audience: Administrator
Applicable Storage: Amazon S3
Problem
Users may encounter an "Access Denied" error when attempting to upload files via eXtendFiles, and eXtendFiles is configured to use Amazon S3.
Cause
The Amazon S3 bucket is set up to restrict public access, meaning that no file in the bucket can be made public. However, the default sharing setting in the eXtendFiles settings is configured to be "Public" instead of "Private".
Resolution
Go to eXtendTech → eXtendFiles → eXtendFiles
Configuration and then
choose Storage Settings → Share Settings from
the lefthand navigation
column.
Set the Default URL/File Share Method as "Private" so that uploaded files are not set to be shared as "Public".
