Version: eXtendFiles 1.6.3 and above
Audience: Administrator
Applicable Storage: Amazon S3

Problem

Users are encountering an "Access Denied" error when attempting to upload files via eXtendFiles, and eXtendFiles is configured to use Amazon S3.

Cause

The Amazon S3 bucket is set up to restrict public access, meaning that no file in the bucket can be made public. However, the default sharing setting in the eXtendFiles settings is configured to be "Public" instead of "Private".

Resolution

In the eXtendFiles Setup page's Sharing Settings, set the DEFAULT URL/FILE SHARING METHOD as "Private" so that uploaded files aren't attempted to be set as "Public".
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