Version: eXtendFiles all versions
Audience: Administrator
Problem
In an eXtendFiles installation utilizing Amazon S3 for backend storage, an "Internal server error" message is displayed when attempting to upload an eXtendFiles record.

Cause
The issue is related to whitespace being included in the S3 bucket name on the eXtendFiles Configuration page.

Solution
Remove any whitespace from the bucket name in your eXtendFiles Amazon S3 configuration.