Version: eXtendFiles 1.7.0 and above
Audience: Administrator
Problem
Upon opening a file from the eXtendFiles Inline Link View, you see an error message instead of being able to see your file. The error message is: "The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint."
Cause
This error occurs when there is a mismatch between the AWS Region configured in eXtendFiles and the actual region where your S3 bucket is located.
Solution
To resolve this issue:
- Navigate to the eXtendTech → eXtendFiles → eXtendFiles
Configuration page using a NetSuite Administrator role.
- Click on Storage Settings -> General in the lefthand navigation column and verify that the AWS Region matches your S3 bucket's region.

Consult your AWS administrator to confirm the correct region if needed.
For reference, you can view Amazon's complete list of region codes and region names here.