Version: eXtendMobile 1.12 and above
Audience: eXtendMobile Admin

Problem

Users receive the following error message when executing an eXtendMobile function:

An nlobjSearchColumn contains an invalid column, or is not in proper syntax: fieldname

Cause

When adding fields to an eXtendMobile function's form, the internal id is automatically set as both the internal id and search id for the field. However, some fields have different search ids than their internal ids, which causes this error during function execution.

This occurs because eXtendMobile cannot automatically retrieve the proper search id from NetSuite when adding fields within a function.

Solution

  1. Access NetSuite's Records Browser
  2. Navigate to your record type
  3. Locate the field in the "Search Columns" section
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  4. Update the function to use the correct search id for the field

Note: If you cannot find a field's search id in the Records Browser, verify that the field is available as a results column in a NetSuite saved search. If it's not available there, the field cannot be referenced within eXtendMobile.

Examples

For the Date Created field:

  • Internal ID: createddate
  • Search ID: datecreated