Version: eXtendMultiFulfillment all versions
Audience: Users

Problem

When you try to start the multi-fulfillment generation process on a sales order, you see the error message "No Item Fulfillment record found in NetSuite for SalesOrder Id XXXXXX" in the eXtendMultiFulfillment logs and/or in an email notification from NetSuite.

Cause

There is no source item fulfillment on the sales order yet. eXtendMultiFulfillment needs an existing item fulfillment so it can gather the fulfillment details and use your pre-fulfillment configuration to generate the required item fulfillment records.

Solution

  1. Create an item fulfillment for the sales order in Picked or Packed status for the items and inventory details that will be processed by eXtendMultiFulfillment.

    Note: Depending on your eXtendMultiFulfillment settings, Shipped status may be supported as well.

  2. Trigger the multi-fulfillment generation process.

    During processing, eXtendMultiFulfillment gathers the details from the source item fulfillment, deletes the source item fulfillment, and generates new item fulfillments based on your pre-fulfillment configuration.