Version: eXtendCreditConnect 1.0.7 and above
Audience: Administrator

Problem

During a scheduled run of eXtendCreditConnect, you may encounter the following error in NetSuite's script logs: {"code":400,"body":"{\\\\"$id\\\\":\\\\"1\\\\",\\\\"Message\\\\":\\\\"Rate limit exceeded\\\\"}"}

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Cause

The primary cause of this error is that the customer list has more customers requiring ASI credit score updates than the ASI Connect service allows in one session.

Impact

When the Rate limit exceeded error occurs, the script stops processing until the next scheduled run.

Solution

The eXtendCreditConnect service resumes during the next scheduled run. It prioritizes updating the customers who were updated least recently and those with the lowest credit scores.

Alternatively, you can modify the associated saved search (CUSTOMER SAVED SEARCH ID field on the eXtendCreditConnect Setup page) to limit the number of customers updated during the scheduled run. For instance, instead of updating every customer daily, consider only updating customers whose scores are older than seven days, or other suitable timeframe.