Version: eXtendMultiFulfillment 1.0.1 and above
Audience: Administrator, User

Problem

When you add or update prefulfillment records using the CSV import method or the manual method, you see one or both of these errors in the Multifulfillment Logs:

  • "An error occurred while creating fulfillments from Prefulfillment records"
  • "You cannot create an inventory detail for this item"
Image Placeholder

Cause

In most cases, NetSuite cannot create the item fulfillment because required inventory and location information is missing or inconsistent.

Common causes include:

  • One or more Sales Order lines do not have a Location.
  • The item requires inventory detail and NetSuite cannot create that inventory detail during fulfillment.

Solution

Try the following solutions in order.

Solution 1: Set a location on every sales order line

  1. Open the Sales Order related to the failed prefulfillment record.
  2. On the Items subtab, confirm every line has a Location.
  3. Save the Sales Order.
  4. Re-run the prefulfillment process.

Solution 2: Copy location from the source item fulfillment

If the Sales Order lines do not consistently have a location, you can copy the location from the source item fulfillment line using the eXtendMultiFulfillment SuiteScript hook.

  1. In NetSuite, go to DocumentsFilesFile Cabinet.
  2. Open SuiteScriptseXtendTech, then open suite_multifulfillment_fields.js in edit mode.
  3. Add location to columnFields (and any other fields you need for your version).
  4. Save the file and re-test.

Example snippet:

/** * @NModuleScope Public */
define([], function() {
    var bodyFields = ['trandate', 'shipstatus'];
    var columnFields = ['location'];
    return {
        bodyFields: bodyFields,
        columnFields: columnFields
    }
});