Version: eXtendSAGE-DE 1.0.0
Audience: Administrator, User
Problem
"Search error occurred: Record 'employee' was not found." during eXtendSAGE-DE item search.
Cause
Users lack appropriate permissions to access their SAGE KEY stored on their employee record. Specifically, their NetSuite role does not include permission to view employee records.
Solution
- Grant the user's NetSuite role permission to view employee records
OR
- Update the "eXtendSageDE Suitelet" script deployment to run with a role that has the required permission
Once the appropriate permissions are assigned, you should be able to perform an item search without encountering the error message.