Audience: Administrator, User

Problem

An eXtendTech application (eXtendApp) or integration is returning the error "Invalid Login Attempt" when performing operations which need to authenticate with NetSuite.

Potential apps:
  • eXtendApproval (part of eXtendFiles)
  • eXtendFloor
  • eXtendFloorXL
  • eXtendFrame
  • eXtendMobile
  • eXtendNS2NS
  • eXtendPresentation
  • eXtendPS-SE
  • eXtendSearch
  • eXtendVendorRFQ
  • eXtendWebApprovals

Potential Causes

This error will occur when the access tokens which are assigned to the eXtendApp are either incorrect, no longer available, or expired.

Some possible scenarios are:
  • If the role which is associated with the eXtendApp has be removed from the associated employee record in NetSuite.
  • If the access tokens which are associated with the eXtendApp have been revoked.
  • If login access has been removed from the associated employee record in NetSuite.
  • This error will occur within a Sandbox environment after it has been refreshed from Production. NetSuite does not copy access tokens from Production to Sandbox during a refresh and causes them to be incorrect within Sandbox until they are regenerated.
  • This error will occur within a Release Preview environment after it has been provisioned by NetSuite. Similar to a Sandbox account, access tokens are not copied from Production during provisioning.

Resolution

To resolve this issue, regenerate access tokens within the appropriate NetSuite environment and enter the new access tokens on the eXtendApp's configuration page. Generating a new Access Token.

Note: Your NetSuite Administrator may be needed for generating the new access tokens.